Excel glossary

Wat is een celverwijzing

Een celverwijzing verwijst naar de waarde in een andere cel of naar een celbereik (cell range) op het huidige werkblad of op een ander werkblad van dezelfde spreadsheet. Een celverwijzing kan als variabele in een formule worden gebruikt.

De meest eenvoudige celverwijzing krijgen we door de cel waarnaar we willen verwijzen te benoemen na een ‘=’ (is gelijk aan) operator. Bijvoorbeeld (=C5) verwijst naar de waarde in cel C5. Het betekent dat de waarde van de huidige cell gelijk is aan de waarde in cel C5.

Example of a simple cell reference // PerfectXL

Verwijzing naar een celbereik

De notatie (=A1:C6) verwijst naar celbereik A1 tot en met C6. Onafhankelijk betekent het niets en zal Excel de standaard foutmelding ‘#WAARDE!’ (#VALUE! in het Engels) tonen als resultaat. Je kunt meer informatie vinden over standaard Excel foutmeldingen in onze Excel Guideline voor Professionals: Negeer nooit Excel foutmeldingen!

Reference to a cell range // Standard Excel error // PerfectXL

Celverwijzing in een functie

Wanneer de verwijzing naar een celbereik wordt gebruikt in een functie, dan zie je ineens wat het nut ervan is. Bijvoorbeeld =SOM(A1:C6) geeft als resultaat de optelling van alle waarden binnen het bereik A1 tot en met C6.

Reference to a cell range in a function in Excel // PerfectXL

En =GEMIDDELDE(A1:C6) (of =AVERAGE(A1:C6) in de Engelstalige editie van Excel) geeft het gemiddelde van alle waardes binnen dit bereik.

Calculating the AVERAGE value of a cell range in Excel // PerfectXL

Celverwijzingen en problemen met bereik

Grote spreadsheets zitten doorgaans bomvol met formules met celverwijzingen. Als spreadsheets in de loop der tijd worden uitgebreid kunnen er daarom verschillende problemen voordoen met verwijzingen naar celbereik. Deze problemen zijn doorgaans moeilijk te vinden, maar erg risicovol! We hebben grote getallen en geldsommen zien ‘verdwijnen’ door dergelijke problemen.

Bepaalde risico’s die te maken hebben met celverwijzing en verwijzingen naar celbereik in spreadsheets komen zeer regelmatig voor. Zoals verwijzingen naar lege cellen, verwijzingen naar samengevoegde cellen of wanneer het bereik waarnaar verwezen wordt niet alle waarden meeneemt omdat de tabel is gegroeid. PerfectXL detecteert deze risico’s en biedt subtiele suggesties om de problemen te verbeteren.