Wat is formulebereik (formula range)

Met formulebereik wordt in Excel doorgaans een verwijzing naar een groep cellen in een spreadsheet bedoeld, waarbinnen een bepaalde formule consistent wordt doorgezet. De celverwijzingen in deze formule kunnen daarentegen relatief zijn.

 

Een formulebereik, zoals een celbereik, wordt gedefinieerd door een referentie naar de cel linksboven en een referentie naar de cel rechtsonder van het bereik.

Voorbeeld van een formulebereik

In het voorbeeld hieronder zien we een formulebereik (C1:C5). De definitie van dit formulebereik wordt bepaald door de minimale waarde (C1, de cel linksboven) en de maximale waarde (C5, de cel rechtsonder).

De formule =SOM(A1:B1) wordt doorgezet binnen het gehele formulebereik, oftewel, dezelfde formule komt voor in iedere cel binnen dit bereik. De celverwijzing in deze formule is echter relatief ten opzichte van de positie van de formule binnen het bereik: in cel C1 zien we de berekening van de som van A1 en B1, maar in cel C2 zien we de berekening van de som van A2 en B2 en in cel C3 zien we de berekening van de som van A3 en B3, enzovoort.

What is a Formula Range :: Excel Glossary :: PerfectXL Spreadsheet Validation Tool

Problemen met formulebereik

Er kunnen verschillende problemen voorkomen in formulebereiken, zoals verwijzingen naar lege cellen. Referenties naar samengevoegde cellen kunnen ook problemen veroorzaken, omdat er meerdere celnamen beschikbaar zijn voor dergelijke verwijzingen, maar er slechts 1 correct is. Ten slotte komt het regelmatig voor dat een formulebereik wordt onderbroken, bijvoorbeeld door een numerieke waarde. Omdat de cellen binnen het bereik slechts het resultaat (de waarde) van de formule laten zien, is het heel lastig om een dergelijke onderbreking te ontdekken.

PerfectXL ontdekt dergelijke problemen met formulebereik en brengt ze onder de aandacht.

Lees meer over de mogelijkheden van PerfectXL m.b.t. problemen met ranges