Verklarende woordenlijst

ALS Functie (IF) in Excel

De ALS functie in Excel voert een logische vergelijking tussen twee waarden uit. Het resultaat van de ALS functie (IF) is WAAR (TRUE) of ONWAAR (FALSE). We kunnen bijvoorbeeld testen of de waarde in cel B2 groter is dan de waarde in cel A2. Zo ja, dan is het resultaat WAAR, zo niet, dan is het resultaat ONWAAR.

Hoe gebruik je de ALS functie?

Een ALS functie in Excel bestaat uit drie componenten:

  1. Een logische test, waarbij een operator gebruikt wordt;
  2. Een waarde die wordt weergegeven als de test resulteert in ‘WAAR’;
  3. Een waarde die wordt weergegeven als de test resulteert in ‘ONWAAR’;

Voorbeeld: =ALS(A1>B2; “WAAR”; “ONWAAR”)

Voorbeeld
Je bent eigenaar van een groentewinkel en je hebt een lijst met de fruitsoorten die je op voorraad hebt. Zodra de voorraad kleiner is dan 20 stuks, moet je een nieuwe order plaatsen bij de groothandel. De ALS functie in Excel kan je helpen bij deze taak. ALS de voorraad kleiner is dan 20 (WAAR), moet je een bestelling plaatsen. ALS de voorraad 20 is of meer (ONWAAR), dan hoef je geen actie te ondernemen.

We maken de functie aan in de kolom ‘Status’: =ALS(B2<20;”ORDER”;”No action”):

Example of how to call the IF function in Excel // PerfectXL

Zodra we op enter drukken, publiceert de functie de waarde voor ‘ONWAAR’: No action, want de waarde in cel B2 is niet kleiner dan 20.

Vervolgens breiden we het formule bereik van de ALS functie uit naar de relevante cellen binnen de Status kolom, om de resultaten voor alle fruitsoorten te zien:

Extend the IF function within a relevant cell range // PerfectXL

Nu zien we precies welke fruitsoorten we moeten bijbestellen.

Genestelde ALS functie

Het is mogelijk om een ALS functie als een WAAR of ONWAAR waarde te gebruiken in een andere ALS functie. Op deze manier kun je diverse voorwaarden toetsen binnen één formule en meer dan twee uitkomsten programmeren als resultaat.

Voorbeeld
We gebruiken dezelfde lijst met fruit, maar dit keer willen we meer. We gaan de fruitsoorten waar de voorraad kleiner is dan 20 stuks bijbestellen en we gaan de fruitsoorten waarbij de voorraad groter dan of gelijk aan 30 is uitverkopen.

In dit geval vervangen we de ONWAAR waarde door een tweede ALS functie: =ALS(B2<20;”Order”;IF(B2=>30;”Sale”;”No action”)):

Example of a nested IF function in Excel // PerfectXL

Op enter klikken toont het resultaat in cel C2. Opnieuw breiden we het formulebereik uit over alle relevante cellen van kolom C, om erachter te komen welke fruitsoorten bijbesteld moeten worden en welke in de uitverkoop moeten:

Example of a nested IF function in Excel // PerfectXL

Genestelde ALS functie zijn risicovol

Een spreadsheet ontwikkelaar kan welke 64 ALS functie nestelen binnen één formule! Je kunt je dus wel voorstellen dat genestelde ALS functies heel verwarrend en complex kunnen worden om te lezen. Daarom markeert PerfectXL genestelde ALS functies als risico. Je kunt zelf bekijken of je aanpassingen wilt maken of niet.